WordPress Eklentisi LiteSpeed Cache, Bilgisayar Korsanlarının Hassas Bilgileri Çalmasına İzin Verebiliyor

Çok fazla kullanılan bir WordPress eklentisi, bilgisayar korsanlarının hassas bilgileri çalmasına izin verebilecek, siteler arası bir komut dosyası saldırısına karşı savunmasız olduğu ortaya çıktı.

Saldırganların ayrıcalıklarını yükseltmelerine izin veren bir WordPress eklentisi bulundu

Güvenlik araştırmacıları tarafından keşfedilen açık, yayınlanmadan önce geliştiricilere bildirildi. Habere göre söz konusu eklentinin adı LiteSpeed Cache. Eklenti, web sitesi performansını artırmaya ve optimize etmeye yarıyor.

Bilgisayar Korsanlarının Hassas Bilgileri Çalmasına İzin Verebiliyor” src=”http://rss.haberler.com/partner/RssImage.aspx?img=https://ares.shiftdelete.net/2024/02/litespeed-cache-wordpress-eklentisi.jpg&width=600&quality=100″/>

Eklenti dört milyondan fazla internet sitesinde aktif kullanılıyor ve hatta 5 milyon olduğu da iddia ediliyor. Site çapında depolanmış XSS açığı olarak tanımlanan bu güvenlik açığı, tek bir HTTP isteği gerçekleştirilerek istismar edilebiliyor ve şu an CVE-2023-40000 olarak takip ediliyor.

Araştırmacılar blogda “Bu güvenlik açığı, kullanıcıdan gelen girdiyi işleyen kodun çıktı kaçışını uygulamaması nedeniyle ortaya çıkıyor. Bu durum aynı zamanda eklentinin mevcut REST API uç noktalarından birinde uygunsuz erişim kontrolü ile birleşti” şeklinde açığı açıkladılar.

Yapay zekada ortalık kızışıyor! Mistral, Microsoft ile ortaklık kurdu

Açığın keşfedilmesinin ardından LiteSpeed Cache’in geliştiricileri bir yama da yayınladı. Bu WordPress eklentisi sitelerinde aktif olan kullanıcıların, eklentilerini en az 5.7.0.1 sürümüne güncellemeleri tavsiye ediliyor.

Bir yanıt yazın

E-posta adresiniz yayınlanmayacak. Gerekli alanlar * ile işaretlenmişlerdir

xxx